Rincon Phones and Network Partially Down
Resolved
This incident has been resolved.
Posted Apr 15, 2024 - 16:37 PDT
Investigating
Phones and network connectivity is currently down. We will update as soon as a resoultion is found.
Posted Apr 15, 2024 - 11:12 PDT
This incident affected: Phone System (Voice Service).