Frevvo Online Forms experiencing issues with logon and queries
Incident Report for EUSD Technology Services Status
Resolved
This incident has been resolved.
Posted Feb 16, 2021 - 11:03 PST
Update
Issue with student login lookup has been resolved.
Posted Feb 16, 2021 - 10:30 PST
Monitoring
The logon issue has been resolved. Working on the Student Login Info search. Temporary workaround is to export this information out of PowerSchool.
Posted Feb 16, 2021 - 08:28 PST
Investigating
We are currently investigating this issue.
Posted Feb 16, 2021 - 08:12 PST
This incident affected: Frevvo Online Forms.