PowerSchool Authentication Outage

Resolved

PowerSchool is back online for all users.
Posted Oct 27, 2025 - 16:14 PDT

Investigating

We are continuing to investigate the PowerSchool issue that is preventing successful login. We will update here when the issue is resolved. Thank you for your patience.
Posted Oct 27, 2025 - 13:22 PDT
This incident affected: PowerSchool (EUSD PowerSchool Interface).