Destiny - navigation issues (system errors)
Incident Report for EUSD Technology Services Status
Resolved
This incident has been resolved.
Posted Jan 08, 2021 - 15:44 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 07, 2021 - 10:08 PST
Update
Destiny has more functions affected this morning 1/7/2021. The issue is being researched and worked on.
Posted Jan 07, 2021 - 07:31 PST
Update
Circulation is functioning again. Destiny Discover is still unavailable.
Posted Jan 06, 2021 - 14:36 PST
Identified
System error messages come up when attempting to use circulation functions and accessing Destiny Discover. We are working with our team and Follett support to resolve the issue.
Posted Jan 06, 2021 - 09:54 PST
This incident affected: Libraries System (Destiny).