Unable to access tasks via emails sent by Frevvo
Incident Report for EUSD Technology Services Status
Resolved
This incident has been resolved.
Posted Feb 16, 2021 - 12:58 PST
Identified
When accessing tasks via emails sent by Frevvo notification system, users will see an HTTP 400 error. The workaround is to log into eusd.org/forms and process any outstanding tasks through My Items > Task List. We're working with support to have the issue resolved.
Posted Feb 16, 2021 - 11:20 PST
This incident affected: Frevvo Online Forms.