Ongoing Apple Classroom Issues
Resolved
Apple Classroom is operational
Posted Jul 02, 2021 - 15:14 PDT
Update
Most accounts are operational.
Posted Feb 16, 2021 - 10:30 PST
Update
Please be aware that Apple Classroom functionality is still limited at this time. We are working with Apple support to address identified issues and are taking steps to improve overall stability going forward. We've made progress, but are still experiencing account issues that hinder the Apple Classroom experience.

Current limitations:
Teachers may be unable to add some students in Apple Classroom until the issues are resolved.
Joining Classrooms with a join code is no longer an option. Going forward students can be looked up by location and added from a list.
Our technicians are currently working with Apple to create accurate rosters at each location.
Manual class creation will continue to be an option for teachers going forward, it will just look a little different.
We have an "escalated" ticket with Apple Education support and are fine-tuning our entire "native" Apple Environment. We hope to avoid future surprise issues with our Apple products and services going forward by working with Apple Engineers now to create an optimal Apple ecosystem that can keep up with our ever-changing technology demands.

Thanks for your patience while we diligently work toward a solution.
Posted Jan 29, 2021 - 14:53 PST
Update
Apple School Manager is now connected to PowerSchool for account and roster creation. We're continuing to work with Apple Support on ensuring older accounts and classes are transferred to correct locations/sites.
Posted Jan 19, 2021 - 08:59 PST
Update
Working with Apple Support on merging existing classes and accounts into correct sites. Sync with PowerSchool has not been enabled at this time. If creating accounts manually, please use sites prefixed with "EUSD".
Posted Jan 13, 2021 - 09:31 PST
Monitoring
Correct sites are prefixed with EUSD
Incorrect sites are prefixed with OLD - DO NOT USE
Moving accounts from old to correct sites is a work in progress.
Posted Jan 06, 2021 - 14:38 PST
Update
We are continuing to work on a fix for this issue.
Posted Dec 29, 2020 - 09:55 PST
Update
We are continuing to work on a fix for this issue.
Posted Dec 16, 2020 - 10:21 PST
Identified
Please be aware that Apple Classroom functionality may be limited at this time. We are working with Apple support to address identified issues and are taking steps to improve overall stability going forward.

Over the past 6 weeks, Apple made several changes to the way classes are created in their latest updates to Apple Classroom and Apple School Manager. As a result, Apple Classroom works differently, and currently has some account/access issues. We've identified the issues and are taking appropriate steps with guidance from Apple engineers.

The recommended fix will take several technician hours to resolve, but rest assured, this is a high priority for our team.

Current limitations::
Teachers may be unable to add some students in Apple Classroom until the issues are resolved.
Joining Classrooms with a join code is no longer an option. Going forward students can be looked up by location and added from a list.
Our technicians are currently working with Apple to create accurate rosters at each location.
Manual class creation will continue to be an option for teachers going forward, it will just look a little different.

The good news:
We have an "escalated" ticket with Apple Education support and are fine-tuning our entire "native" Apple Environment.
We hope to avoid future surprise issues with our Apple products and services going forward by working with Apple Engineers now to create an optimal Apple ecosystem that can keep up with our ever-changing technology demands.

What can I do for now?
If you are trying to build a class and don't see a particular student, you may be able to locate them in the "Escondido Union School District" location for the time being.
Posted Nov 30, 2020 - 13:09 PST
This incident affected: Apple Classroom (ASM).