PowerSchool Outage. 6/16/2022
Incident Report for EUSD Technology Services Status
Resolved
This incident has been resolved.
Posted Jun 16, 2022 - 08:43 PDT
Investigating
We are aware that PowerSchool is down, and are looking into it.
Posted Jun 16, 2022 - 07:48 PDT
This incident affected: PowerSchool (EUSD PowerSchool Interface).