Nearpod issues on EUSD iPads
Incident Report for EUSD Technology Services Status
Resolved
We made adjustments to our content filter and now affected apps are working again.
Posted Feb 18, 2021 - 12:15 PST
Update
It appears the issues we are currently experiencing extend to multiple applications including the following:

Nearpod
Benchmark
McGraw Hill
iReady

If students are experiencing issues with any of these apps, please have them restart their iPads to see if that helps.  We will continue to keep you updated as information becomes available.
Posted Feb 17, 2021 - 12:08 PST
Update
We are continuing to investigate this issue.
Posted Feb 17, 2021 - 11:25 PST
Investigating
We are getting reports of Nearpod issues on EUSD iPads. We have created a support ticket with our content filter provider to check if any Nearpod resources are being blocked.
Posted Feb 17, 2021 - 11:18 PST
This incident affected: iPads.