Lexia English is down
Resolved
Lexia Servers are back to normal
Posted Dec 13, 2022 - 09:23 PST
Investigating
Lexia English is currently down. The vendor is working on identifying and resolving the issue.
https://status.lexialearning.com/
Posted Dec 08, 2022 - 09:37 PST